Spring Boot System Requirements and Compatibility


Spring Boot required the below configuration for developing an application.

JDK Version Range

Although, Spring Boot Application can be developed with Java 6 or 7 but most recommended to use Java 8 if possible.

  • Spring Framework 5.3.x: JDK 8 to JDK 17 (expected)
  • Spring Framework 5.2.x: JDK 8 to JDK 15 (expected)
  • Spring Framework 5.1.x: JDK 8 to JDK 12
  • Spring Framework 5.0.x: JDK 8 to JDK 10
  • Spring Framework 4.3.x: JDK 6 to JDK 8

Build Tool

You can choose either build tool Maven or Gradle for developed Spring Boot Java Applications.

  • Maven 3.2+
  • Gradle [2.9, 3.x]

Servlet Containers

Spring Boot application can be deployed on any compatible servlet containers 3.0+. Here is a list of supported embedded servlet containers:

Server Name Servlet Version Java Version
Tomcat 8 3.1 Java 7+
Tomcat 7 3.0 Java 6+
Jetty 9.3 3.1 Java 8+
Jetty 9.2 3.1 Java 7+
Jetty 8 3.0 Java 6+
Undertow 1.3 3.1 Java 7+

IDE

Although Spring Boot application can be developed on IDE like NetBeans, Eclipse, etc. but most recommended IDE is STS (Spring Tool Suite).

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s